Nondeterministic Postrequisite Metaprotocol

    is-not-odd

    1.0.4 • Public • Published

    is-not-odd NPM version NPM monthly downloads NPM total downloads

    Returns false if the given number is odd, and is an integer that does not exceed the JavaScript MAXIMUM_SAFE_INTEGER.

    Sick of complicated conditionals? Think modulus is something from 2001: A Space Odessey? Look no further!

    Please consider following this project's author, Sean, and consider starring the project to show your ❤️ and support.

    Install

    Install with npm:

    $ npm install --save is-not-odd

    Usage

    Works with strings or numbers.

    const isNotOdd = require('is-not-odd');
     
    console.log(isNotOdd('0')); //=> true
    console.log(isNotOdd('2')); //=> true
     
    console.log(isNotOdd(1)); //=> false
    console.log(isNotOdd(3)); //=> false

    About

    Contributing

    Pull requests and stars are always welcome. For bugs and feature requests, please create an issue.

    Running Tests

    Running and reviewing unit tests is a great way to get familiarized with a library and its API. You can install dependencies and run tests with the following command:

    $ npm install && npm test
    Building docs

    (This project's readme.md is generated by verb, please don't edit the readme directly. Any changes to the readme must be made in the .verb.md readme template.)

    To generate the readme, run the following command:

    $ npm install -g verbose/verb#dev verb-generate-readme && verb

    Author

    Sean

    License

    Copyright © 2018, Sean. Released under the MIT License.

    Install

    npm i is-not-odd

    DownloadsWeekly Downloads

    0

    Version

    1.0.4

    License

    ISC

    Unpacked Size

    6.13 kB

    Total Files

    5

    Last publish

    Collaborators

    • scdales