Neat Paraskavedekatriaphobia's Meaning

    de-express

    3.0.1 • Public • Published

    de-express

    dependencies Status devDependencies Status code style: prettier build license

    npm


    de-express is a simple way to use express with ES6 decorators.

    Install

    $ yarn add -D @babel/cli @babel/core @babel/node @babel/preset-env @babel/plugin-transform-runtime
    # npm install --save-dev @babel/cli @babel/core @babel/node @babel/preset-env @babel/plugin-transform-runtime 
     
    $ yarn add -D @babel/plugin-proposal-decorators @babel/plugin-proposal-class-properties
    # or npm install --save-dev @babel/plugin-proposal-decorators @babel/plugin-proposal-class-properties 
     
    $ yarn add de-express
    # or npm install de-express 

    .babelrc

    {
      "presets": ["@babel/env"],
      "plugins": [
        "@babel/transform-runtime",
        ["@babel/plugin-proposal-decorators", { "legacy": true }],
        ["@babel/proposal-class-properties", { "legacy": true }]
      ]
    }

    Usage

    Visit the wiki.

    Install

    npm i de-express

    DownloadsWeekly Downloads

    1

    Version

    3.0.1

    License

    GPL-3.0

    Unpacked Size

    118 kB

    Total Files

    61

    Last publish

    Collaborators

    • htdangkhoa