npm

Join us for the upcoming webinar, "Enterprise JavaScript done right: the tools you love, the security you need."Sign up here »

upgrade-dependents

1.1.0 • Public • Published

Upgrade Dependents

A utility to upgrade package dependents.

npm Version MIT License Travis CI Build Status

Overview

Upgrade Dependents will discover and upgrade all compatible dependents within a directory.

Features

  • Adheres to Semantic Versioning 2.0.0 — no unexpected breaking changes
  • Support for Semantic Release — seamless configuration via a plugin
  • Yarn workspaces detection — simply run the command in a package directory
  • CLI utility — for ad hoc uses
  • Dry run mode — test without fear

Usage

CLI

The utility can be used without any configuration or installation with npx, which is available with npm@5.2.0 or later.

cd /workspace/packages/my-package
npx upgrade-dependents --help

Programmatically

Upgrade Dependents can be used programmatically via import.

import upgradeDependents from 'upgrade-dependents';
 
upgradeDependents("/workspace/packages/my-package");

Semantic Release

Upgrade Dependents can also be used as a plugin for Semantic Release. This is particularly useful when used with Semantic Release Monorepo.

Example configuration:

/workspace/packages/my-package/package.json

{
  "release": {
    "prepare": [
      "@semantic-release/changelog",
      "@semantic-release/npm",
      "upgrade-dependents/semantic-release"
      "@semantic-release/git"
    ]
  }
}

Installation

Node.js via Yarn

yarn add upgrade-dependents -D

Node.js via npm

npm i upgrade-dependents -D

License

Copyright © 2018 Morris Allison III.
Released under the MIT license.

install

npm i upgrade-dependents

Downloadsweekly downloads

45

version

1.1.0

license

MIT

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
Report a vulnerability