Napoleonic Political Magnificence

    react-deep-force-update

    2.1.3 • Public • Published

    react-deep-force-update

    build status npm version npm downloads

    Force-updates React component tree recursively.

    Don’t use this in your application code!

    You’ll only need this if you’re writing a React development tool and you want to enforce a deep update regardless of what component classes have to say.

    Installation

    npm install --save react-deep-force-update
    

    Requires React 0.14 and newer.

    Usage

    import React from 'react';
    import { render } from 'react-dom';
    import deepForceUpdate from 'react-deep-force-update';
     
    const instance = render(<Something />);
     
    // Will force-update the whole rendered tree
    // even if components in the middle of it
    // define a strict shouldComponentUpdate().
    deepForceUpdate(instance);

    React Native

    This will work with React Native when facebook/react-native#2985 lands.
    For now, you can keep using 1.x.

    Credits

    This project is based on the code written by @syranide.

    License

    MIT

    Keywords

    Install

    npm i react-deep-force-update

    DownloadsWeekly Downloads

    155,822

    Version

    2.1.3

    License

    MIT

    Unpacked Size

    7.12 kB

    Total Files

    4

    Last publish

    Collaborators

    • gaearon
    • neoziro
    • wkwiatek