This package has been deprecated

Author message:

Not maintained anymore.

postcss-layout-selector

0.2.5 • Public • Published
PostCSS Logo

PostCSS Layout Selector
Downloads Downloads Build Status Dependencies

PostCSS plugin for easy handling of different layouts without media queries but with conditional compilation.

header {
  background: #eee;
 
  @layout landscape {
    height: 75px;
  }
 
  @layout portrait {
    height: 150px;
  }
}

Generating "landscape" version:

header {
  background: #eee;
  height: 75px;
}

Generating "portrait" version:

header {
  background: #eee;
  height: 150px;
}

Links

Installation

Should be installed locally in your project source code:

npm install postcss-layout-selector --save-dev

Usage

Integrate like this in your e.g. gulpfile.js:

postcss([
  require("postcss-layout-selector")({
    layout: "portrait"
  })
])

See PostCSS docs for examples for your environment.

Copyright

Sebastian Software GmbH Logo

Copyright 2015-2016
Sebastian Software GmbH

Package Sidebar

Install

npm i postcss-layout-selector

Weekly Downloads

3

Version

0.2.5

License

Apache-2.0

Last publish

Collaborators

  • swernerx