Nutritious Pancake Mountain

    gulp-conflict

    0.4.0 • Public • Published

    gulp-conflict NPM version Build Status Dependency Status

    Check if files in stream conflict with those in target dir, with option to use new, keep old, show diff, etc.

    Primary objective

    Used before any gulp.dest step when using slush as a Yeoman replacement.

    Installation

    For global use with slush

    Install gulp-conflict as a dependency:

    npm install --save gulp-conflict

    For local use with gulp

    Install gulp-conflict as a development dependency:

    npm install --save-dev gulp-conflict

    Usage

    In your slushfile.js:

    var conflict = require("gulp-conflict");
     
    gulp.src(__dirname + '/templates/**')
      .pipe(conflict('./'))
      .pipe(gulp.dest('./'));

    In your gulpfile.js:

    var install = require("gulp-conflict");
     
    gulp.src(['./files/*.js'])
      .pipe(conflict('./dir'))
      .pipe(gulp.dest('./dir'));

    API

    conflict(dest, options)

    dest

    Type: String, required

    Specify destination directory to compare files in, should be the same as destination directory for gulp.dest.

    options

    Type: Object, optional

    options.cwd - specify another working directory than process.cwd()

    options.defaultChoice - default choice on conflicts e.g. 'y' (replace, default), 'n' (skip), 'd' (diff)

    License

    MIT License

    Install

    npm i gulp-conflict

    DownloadsWeekly Downloads

    208

    Version

    0.4.0

    License

    MIT

    Last publish

    Collaborators

    • joakimbeng