npm

Ready to take your JavaScript development to the next level? Meet npm Enterprise - the ultimate in enterprise JavaScript.Learn more »

This package has been deprecated

Author message:

gulp-browser has been deprecated in favour of @pushrocks/gulp-browser - please upgrade asap!!!

gulp-browser

3.0.11 • Public • Published

gulp-browser

browserify and other goodies for gulp

Availabililty

npm git git docs

Status for master

build status coverage report npm downloads per month Dependency Status bitHound Dependencies bitHound Code TypeScript node JavaScript Style Guide

Usage

Use TypeScript for best in class instellisense.

Browserify:

let gulp = require('gulp');
let gulpBrowser = require('gulp-browser');
 
let transforms = [
  {
    transform: 'babelify',
    options: { presets: ['es2015'] }
  }
];
 
gulp.task('gulpBrowserTest', function() {
  var stream = gulp
    .src('./test/*.js')
    .pipe(gulpBrowser.browserify(transforms)) // gulp.browserify() accepts an optional array of tansforms
    .pipe(gulp.dest('./test/browserifiedJS/'));
  return stream;
});

Note: Be aware of how gulp.src creates values of file.base and file.path since that is important to the require statements.

Contributors

For further information read the linked docs at the top of this README.

MIT licensed | © Lossless GmbH | By using this npm module you agree to our privacy policy

repo-footer

install

npm i gulp-browser

Downloadsweekly downloads

352

version

3.0.11

license

MIT

homepage

gitlab.com

repository

Gitgitlab

last publish

collaborators

  • avatar
Report a vulnerability