Nested Parenthetical Madness
Learn about our RFC process, Open RFC meetings & more.Join in the discussion! »

grunt-puglint

1.0.0 • Public • Published

grunt-puglint

Grunt plugin for pug-lint (formerly Jade).

Travis NPM version devDependency Status devDependency Status

image

Getting Started

This plugin requires Grunt ~1.0.0

If you haven't used Grunt before, be sure to check out the Getting Started guide, as it explains how to create a Gruntfile as well as install and use Grunt plugins. Once you're familiar with that process, you may install this plugin with this command:

npm install grunt-puglint --save-dev

Once the plugin has been installed, it may be enabled inside your Gruntfile with this line of JavaScript:

grunt.loadNpmTasks('grunt-puglint');

Usage

To configure validator, use the property config.

puglint: {
  taskName: {
    options: {
      // Use preset: npm i -D pug-lint-config-clock
      config: {
        extends: 'clock'
      },
      // Or config
      config: {
        disallowHtmlText: true,
        validateIndentation: 4
      }
    },
    src: ['test/fixtures/**/*.jade']
  }
 
  // Or short version
  options: {
    // ..
  },
  taskName: ['...']
}

Configuration

Plugin can read .pug-lintrc file.

Rules

List of available rules.

Changelog

See the Releases section of our GitHub project for changelogs for each release version.

License

This software is released under the terms of the MIT license.

Install

npm i grunt-puglint

DownloadsWeekly Downloads

527

Version

1.0.0

License

MIT

Last publish

Collaborators

  • avatar