Learn about our RFC process, Open RFC meetings & more.Join in the discussion! »

eslint-config-blued

1.1.2 • Public • Published

eslint-config-blued

Blued大前端编码规范,基于airbnb所进行的一些符合日常开发习惯的客制化

使用方法

npm5.x以上的版本,可以有快捷的方式来安装所有的依赖:

npx install-peerdeps --dev eslint-config-blued

如果是小于npm5.x版本的,在Linux/OSX环境下可以执行这样的命令:

(
  export PKG=eslint-config-blued;
  npm info "$PKG@latest" peerDependencies --json | command sed 's/[\{\},]//g ; s/: /@/g' | xargs npm install --save-dev "$PKG@latest"
)

如果是小于npm5.x版本的Windows用户,可以通过手动获取依赖进行安装,或者使用install-peerdeps来安装依赖:

获取依赖然后手动安装:

npm info "eslint-config-blued@latest" peerDependencies

使用工具安装:

npm install -g install-peerdeps
install-peerdeps --dev eslint-config-blued

修改项目中的.eslintrc文件,添加extends

extends: blued

上述操作步骤说明修改于airbnb

所有可选的配置

Config Description
blued 基础的规则,适用于所有项目
blued-react 基于基础规则,针对react/jsx所添加的一些增强规则
blued-typescript 基于基础规则,针对TypeScript所添加的一些增强规则

Keywords

none

Install

npm i eslint-config-blued

DownloadsWeekly Downloads

63

Version

1.1.2

License

ISC

Unpacked Size

6.09 kB

Total Files

6

Last publish

Collaborators

  • avatar