cordova-support-kotlin

    1.2.1 • Public • Published

    cordova-support-kotlin

    npm npm

    kotlin-128x128

    This Cordova plugin help you support kotlin to your android project, At the same time you can use other Cordova plugins that rely on kotlin.

    Installation

    Add this plugin in your project:

    cordova plugin add cordova-support-kotlin --save

    Settings

    Kotlin uses the latest version of latest.integration by default. You can set the version you need and configure it like this in your app's config.xml file:

    <platform name="android" kotlin="1.2.50">
        ...
    </platform>

    Set additional apply plugin elements in the app's build.gradle.

    Note that the order matters.

    <platform name="android">
        ...
        <apply-plugin>kotlin-android-extensions</apply-plugin>
        <apply-plugin>kotlin-kapt</apply-plugin>
        ...
    </platform>

    You can also add dependencies if you need to.

    <platform name="android">
        ...
        <apply-dependency>org.jetbrains.kotlinx:kotlinx-coroutines-android:1.3.0-M2</apply-dependency>
        ...
    </platform>

    Install

    npm i cordova-support-kotlin

    DownloadsWeekly Downloads

    32

    Version

    1.2.1

    License

    MIT

    Unpacked Size

    6.1 kB

    Total Files

    6

    Last publish

    Collaborators

    • -kain