afinn-165
TypeScript icon, indicating that this package has built-in type declarations

2.0.2 • Public • Published

afinn-165

Build Coverage Downloads Size

AFINN 165.

Contents

What is this?

This package exposes a map of words rated for valence (“goodness” vs “badness”).

When should I use this?

This package can be used for sentiment analysis of words. You can use emoji-emotion for emoji.

Install

This package is ESM only. In Node.js (version 14.14+, 16.0+), install with npm:

npm install afinn-165

In Deno with esm.sh:

import {afinn165} from 'https://esm.sh/afinn-165@2'

In browsers with esm.sh:

<script type="module">
  import {afinn165} from 'https://esm.sh/afinn-165@2?bundle'
</script>

Use

import {afinn165} from 'afinn-165'

afinn165.xoxo //=> 3
afinn165.bankruptcy //=> -3

API

This package exports the identifier afinn165. There is no default export.

afinn165

Map of words to valence (Record<string, number>).

👉 Note: be careful when accessing unknown properties on the afinn165 object, words such as “constructor” or “toString” might occur. It’s recommended to use a hasOwnProperty check beforehand.

Musings

AFINN 165 contains 3382 entries. 905 entries were added and two were changed. Compared to AFINN 111, the following changed:

  • many new words
  • damn is now rated as -2 (was -4)
  • exasperated, futile, irresponsible are now -2 (were 2)
  • new entries with spaces: damn cute, damn good, kind of, fucking awesome, fucking beautiful, fucking cute, fucking fantastic, fucking good, fucking great, fucking hot, fucking love, fucking loves, fucking perfect
  • new entries with hyphens: environment-friendly, game-changing, ill-fated, loving-kindness, non-approved, post-traumatic, self-abuse, self-contradictory, side-effect, side-effects, violence-related, well-being, well-championed, well-developed, well-established, well-focused, well-groomed, well-proportioned

Types

This package is fully typed with TypeScript. It exports no additional types.

Compatibility

This package is at least compatible with all maintained versions of Node.js. As of now, that is Node.js 14.14+ and 16.0+. It also works in Deno and modern browsers.

Related

  • afinn-96 — AFINN list from 2009 with 1468 entries
  • afinn-111 — AFINN list from 2011 with 2477 entries
  • emoji-emotion — like AFINN but for emoji
  • polarity — detect the polarity of text, based on afinn-169 and emoji-emotion

Contributing

Yes please! See How to Contribute to Open Source.

Security

This package is safe.

License

MIT © Titus Wormer

Package Sidebar

Install

npm i afinn-165

Weekly Downloads

95,804

Version

2.0.2

License

MIT

Unpacked Size

60.9 kB

Total Files

5

Last publish

Collaborators

  • wooorm
  • zeke