Nervous Penpal Message

npm

Need private packages and team management tools?Check out npm Orgs. »

This package has been deprecated

Author message:

this package has been deprecated

@wessberg/rollup-plugin-di

1.0.87 • Public • Published

rollup-plugin-di

NPM version License-mit

A rollup plugin for DI - Compile-time reflection and dependency injection.

Installation

Simply do: npm install @wessberg/rollup-plugin-di.

Usage

Add it to the plugins array of your rollup configuration:

rollup({
  plugins: [
   DI(),
   // Other plugins goes here...
  ]
});

Configuration

You can pass in the following options:

  • excludeFiles: RegExp|RegExp[]|Set<RegExp>
    • Files matching this or these regular expressions will be ignored.
  • shimGlobalObject: boolean
    • By default, the plugin will add a shim for the global object in top of your bundle. You may target an environment where global is defined already (such as Node), and if so, you can set this to false.

See the documentation for more details on how to actually use DI.

install

npm i @wessberg/rollup-plugin-di

Downloadsweekly downloads

84

version

1.0.87

license

MIT

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
Report a vulnerability