Nasty Popsicle Machine

    This package has been deprecated

    Author message:

    this package has been deprecated in favor of create-stylable-app. see: https://github.com/wix/stylable/tree/master/packages/create-stylable-app

    @stylable/react-scripts

    3.4.5 • Public • Published

    @stylable/react-scripts

    npm version

    A fork of react-scripts tailored for quick and easy creation of Stylable projects.

    Major changes from react-scripts

    • Uses TypeScript instead of Babel, configured to work with Webpack's tree-shaking and dynamic chunks on import().
    • Adds built-in support for Stylable.

    Getting started

    This is the quickest way to get a Stylable project up and running. It is an opinionated boilerplate that uses TypeScript and Stylable instead of css-loader

    In your terminal, run:

    $ npx create-react-app@3.2.0 --scripts-version @stylable/react-scripts [APP NAME]
    $ cd [APP NAME]
    $ yarn
    $ yarn start
    

    Note: due to recent changes with how create-react-app handles external customization, we are forced to lock our react-scripts package to an older version of create-react-app (v3.2.0).

    License

    Copyright (c) 2017 Wix.com Ltd. All Rights Reserved. Use of this source code is governed by an MIT license.

    Keywords

    none

    Install

    npm i @stylable/react-scripts

    DownloadsWeekly Downloads

    2

    Version

    3.4.5

    License

    MIT

    Unpacked Size

    123 kB

    Total Files

    34

    Last publish

    Collaborators

    • tzachb
    • tomrav
    • avi.vahl
    • idoros
    • baraki
    • cijoe
    • alexswix