@nomiclabs/hardhat-vyper
TypeScript icon, indicating that this package has built-in type declarations

3.0.6 • Public • Published

hardhat-vyper

npm hardhat

Hardhat plugin to develop smart contracts with Vyper.

What

This plugin adds support for Vyper to Hardhat. Once installed, Vyper contracts can be compiled by running the compile task.

This plugin generates the same artifact format as the built-in Solidity compiler, so that it can be used in conjunction with all other plugins.

The Vyper compiler is run using the official binary releases.

Installation

First, you need to install the plugin by running

npm install --save-dev @nomiclabs/hardhat-vyper

And add the following statement to your hardhat.config.js:

require("@nomiclabs/hardhat-vyper");

Or, if you are using TypeScript, add this to your hardhat.config.ts:

import "@nomiclabs/hardhat-vyper";

Required plugins

No plugins dependencies.

Tasks

This plugin creates no additional tasks.

Environment extensions

This plugin does not extend the Hardhat Runtime Environment.

Configuration

This plugin adds an optional vyper entry to Hardhat's config, which lets you specify the Vyper version to use.

This is an example of how to set it:

module.exports = {
  vyper: {
    version: "0.3.0",
  },
};

You can also configure multiple versions of the Vyper compiler, as well as the compiler settings evmVersion and optimize. See the Vyper docs for more info.

module.exports = {
  vyper: {
    compilers: [
      {
        version: "0.2.1",
      },
      {
        version: "0.3.10",
        settings: {
          evmVersion: "paris",
          optimize: "gas",
        },
      },
    ],
  },
};

Usage

There are no additional steps you need to take for this plugin to work.

Test directives

Brownie allows you to use the test directive #@ if mode == "test": to specify when a portion of code should be included only for testing purposes.

Example:

#@ if mode == "test":
@external
def _mint_for_testing(_to: address, _token_id: uint256):
    self._mint(_to, _token_id)
#@ endif

We do NOT support this feature. An error will be thrown every time that, when compiling a contract, the directive #@ if mode == "test": is found.

Additional notes

The oldest vyper version supported by this plugin is 0.2.0. Versions older than this will not work and will throw an error.

Package Sidebar

Install

npm i @nomiclabs/hardhat-vyper

Weekly Downloads

10,706

Version

3.0.6

License

MIT

Unpacked Size

123 kB

Total Files

63

Last publish

Collaborators

  • schaable
  • kanej
  • fzeoli
  • alcuadrado
  • fvictorio