This package has been deprecated

Author message:

It is recommended to use @googlemaps/markerclusterer instead of this package.

@googlemaps/markerclustererplus
TypeScript icon, indicating that this package has built-in type declarations

1.2.10 • Public • Published

Google Maps JavaScript MarkerClustererPlus

npm Build Release codecov GitHub contributors semantic-release

Description

The library creates and manages per-zoom-level clusters for large amounts of markers.

Note: This library has been refactored into @googlemaps/markerclusterer, check out the new and improved version!

Note: This library is the same as the existing library @google/markerclustererplus, but renamed and in its own repository.

Install

Available via npm as the package @googlemaps/markerclustererplus.

npm i @googlemaps/markerclustererplus

or

yarn add @googlemaps/markerclustererplus

Alternativly you may add the umd package directly to the html document using the unpkg link.

<script src="https://unpkg.com/@googlemaps/markerclustererplus/dist/index.min.js"></script>

When adding via unpkg, the loader can be accessed at MarkerClusterer.

A version can be specified by using https://unpkg.com/@googlemaps/markerclustererplus@VERSION/dist/....

TypeScript

This library uses the official TypeScript typings for Google Maps Platform, @types/google.maps.

npm i -D @types/google.maps

It may also require the skipLibCheck TypeScript compiler option.

Documentation

The reference documentation can be found at this link.

Example

import MarkerClusterer from '@googlemaps/markerclustererplus';

const markerCluster = new MarkerClusterer(map, markers);

View the package in action:

Package Sidebar

Install

npm i @googlemaps/markerclustererplus

Weekly Downloads

87,632

Version

1.2.10

License

Apache-2.0

Unpacked Size

724 kB

Total Files

29

Last publish

Collaborators

  • wangela
  • google-wombot