Necrotizing Pineapple Music

    @fabrix/spool-plv8
    TypeScript icon, indicating that this package has built-in type declarations

    1.1.0-alpha.1 • Public • Published

    spool-plv8

    Gitter NPM version Build Status Test Coverage Dependency Status Follow @FabrixApp on Twitter

    require() and execute nodejs code in Postgres with PLV8 and Fabrix. Depends on spool-knex.

    Install

    $ npm install --save @fabrix/spool-plv8

    Configure

    // config/main.ts
    import { PLV8Spool } from '@fabrix/spool-plv8'
    import { KnexSpool } from '@fabrix/spool-knex'
    export const main = {
      spools: [
        // ... other spools
        KnexSpool,
        PLV8Spool
      ]
    }
    // config/plv8.ts
    export const plv8 = {
      /**
       * The name of the database store to use; must be defined in config.database.stores
       */
      store: 'some-plv8-store'
    }

    License

    MIT

    Install

    npm i @fabrix/spool-plv8

    Homepage

    fabrix.app

    DownloadsWeekly Downloads

    2

    Version

    1.1.0-alpha.1

    License

    MIT

    Unpacked Size

    9.73 kB

    Total Files

    19

    Last publish

    Collaborators

    • scottbwyatt