Get unlimited public & private packages + package-based permissions with npm Pro.Get started »

This package has been deprecated

Author message:

deprecated

@faasjs/provider-postgresql

0.0.0-alpha.0 • Public • Published

@faasjs/provider-postgresql

PostgreSQL 适配

License: MIT Build Status Coverage Status NPM Stable Version NPM Beta Version

接口文档

How to use?

  1. Add npm to package.json: yarn add @faasjs/provider-postgresql@beta;
  2. Config connection info in providers folder, support host, user, password and database;
  3. Use it in flow:
new Flow({
  resources: {
    postgresql: {}
  }
}, async function(){
  const results = await this.postgresql.query('SELECT user from id = ?', ['1']);
  console.log(results[0].id); // => 1
})

Keywords

none

Install

npm i @faasjs/provider-postgresql

DownloadsWeekly Downloads

0

Version

0.0.0-alpha.0

License

MIT

Unpacked Size

6.67 kB

Total Files

6

Last publish

Collaborators

  • avatar