Nostalgic Primordial Monster
Unleash awesomeness. Private packages, team management tools, and powerful integrations. Get started with npm Orgs »

web4js

0.20.9 • Public • Published

Hyperdapp & Theos JavaScript API

Join the chat at https://gitter.im/hyperdapp/web4.js

This is the Ethereum compatible JavaScript API which implements the Generic JSON RPC spec. It's available on npm as a node module, for Bower and component as embeddable scripts, and as a meteor.js package.

NPM version Build Status dependency status dev dependency status Coverage Status Stories in Ready

You need to run a local Ethereum node to use this library.

Documentation

Table of Contents

Installation

Node.js

npm install web4js

Yarn

yarn add web4js

Meteor.js

meteor add hyperdapp:web4js

As a Browser module

CDN

<script src="https://cdn.jsdelivr.net/gh/hyperdapp/web4.js@1.0.0-beta.36/dist/web4.min.js" integrity="sha256-nWBTbvxhJgjslRyuAKJHK+XcZPlCnmIAAMixz6EefVk=" crossorigin="anonymous"></script>

Bower

bower install web4js

Component

component install hyperdapp/web4.js
  • Include web4.min.js in your html file. (not required for the meteor package)

Usage

Use the web4 object directly from the global namespace:

console.log(web4); // {eth: .., shh: ...} // It's here!

Set a provider (HttpProvider):

if (typeof web4 !== 'undefined') {
  web4 = new web4(web4.currentProvider);
} else {
  // Set the provider you want from web4.providers
  web4 = new web4(new web4.providers.HttpProvider("http://localhost:8545"));
}

Set a provider (HttpProvider using HTTP Basic Authentication):

web4.setProvider(new web4.providers.HttpProvider('http://' + BasicAuthUsername + ':' + BasicAuthPassword + '@localhost:8545'));

There you go, now you can use it:

var coinbase = web4.eth.coinbase;
var balance = web4.eth.getBalance(coinbase);

You can find more examples in the example directory.

Migration from web3 to web4

web4.js is derived from web3.js of Ethereum web3 . To migrate to this framework, please follow the guide:

+Run/Connect to Theos Blockchain;
+Deploy Smart Contract;
+Install Smart Contract on Hyperdapp;

Contribute!

Requirements

  • Node.js
  • npm
# On Linux: 
sudo apt-get update
sudo apt-get install nodejs
sudo apt-get install npm
sudo apt-get install nodejs-legacy

Building (gulp)

npm run-script build

Testing (mocha)

npm test

Community

Other upcoming implementations

License

MIT © 2018 Contributors

LGPL-3.0+ © 2015 Contributors For any omissions, please contact us at info@hyperdapp.org

install

npm i web4js

Downloadsweekly downloads

0

version

0.20.9

license

LGPL-3.0

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
Report a vulnerability