Neoprene Party Masks

    swf-player-version

    1.1.3 • Public • Published

    SWFPlayerVersion

    Shockwave Flash Player version utility. GCC ADVANCED optimizations compatible.

    // Test if SWF Player version is supported and output the actual version.
    if (SWFPlayerVersion.isSupported('10.0')) {
      alert('SWF Player ' + SWFPlayerVersion.get() + ' is installed');
    }

    API

    get()
      returns {?string} '#.#.#' or null.
    
      Get available SWF Player version. Result is cached.
    
    isSupported(requiredString)
      requiredString {string} '#.#.#', '#.#', '#' or ''.
      returns {boolean} true if supported.
    
      Determine if available SWF Player meets version requirement.
    

    Install

    npm i swf-player-version

    DownloadsWeekly Downloads

    21

    Version

    1.1.3

    License

    MIT

    Last publish

    Collaborators

    • syranide