Learn about our RFC process, Open RFC meetings & more.Join in the discussion! »

snyk-python-plugin

1.17.1 • Public • Published

Snyk logo


Snyk helps you find, fix and monitor for known vulnerabilities in your dependencies, both on an ad hoc basis and as part of your CI (Build) system.

ℹ️ This repository is only a plugin to be used with the Snyk CLI tool. To use this plugin to test and fix vulnerabilities in your project, install the Snyk CLI tool first. Head over to snyk.io to get started.

Snyk Python CLI Plugin

This plugin provides dependency metadata for Python projects that use one of the following dependency management methods:

  • pip with a requirements.txt file
  • pipenv with a Pipefile file

There's a special only-provenance mode that allows extracting of top-level dependencies with their corresponding positions in the original manifest file.

Contributing

Guide

Developing and Testing

Prerequisites:

  • Node.js 6+
  • Python 2.7 or 3.6+
  • Installed outside of any virtualenv:
    • pip
    • the contents of dev-requirements.txt:
      pip install --user -r dev-requirements.txt
      

Tests can be run against multiple python versions by using tox:

pip install tox
tox

Linting and testing:

npm i
npm run lint
npm test

Keywords

none

Install

npm i snyk-python-plugin

DownloadsWeekly Downloads

265,894

Version

1.17.1

License

Apache-2.0

Unpacked Size

108 kB

Total Files

59

Last publish

Collaborators

  • avatar