riot-compiler

    3.6.0 • Public • Published

    Build Status Issue Count Coverage Status NPM version NPM downloads MIT License

    Documentation

    Installation

    Npm

    $ npm install riot-compiler --save

    Read more in the doc folder and the CHANGELOG

    Please note: the documentation is a work in progress. Contributions are welcome.

    For babel users

    • babel - For babel-core v6.x - You must npm install babel-preset-es2015-riot too, for this to work.
    • babel - For @babel/core v7.x - You must set the option "module": "false" in order to compile your tags properly

    Known Issues

    • Expressions within attribute values containing > must be enclosed in quotes. Ex: <mytag hidden="{ a > 5 }">.
    • Shorthands within attributes parsed by CoffeeScript must be prefixed with a caret: <mytag class="{^ c:1 }">

    Install

    npm i riot-compiler

    DownloadsWeekly Downloads

    3,639

    Version

    3.6.0

    License

    MIT

    Unpacked Size

    140 kB

    Total Files

    27

    Last publish

    Collaborators

    • gianlucaguarini