regional-environment

0.1.2 • Public • Published

Node.js regional-environment library

JavaScript Style Guide dependencies status devDependencies status Travis CI downloads version license

What is this?

This is a JavaScript library that helps building regional-environment plugins for code editors

Requirements

  • ECMAScript 6

Usage

// import the module
const regionalenv = require('regional-environment')

// get all items
const allitems = regionalenv.getAllItems(dirname)

// get some items whose name always contains '.myfiletype' and may contain '.atom' and '.x86'
const myitems = regionalenv.getItems(dirname, {
  required: ['myfiletype'],
  optional: ['atom', 'x86'],
  suffix: 'myext'
})

License

MIT

Package Sidebar

Install

npm i regional-environment

Weekly Downloads

0

Version

0.1.2

License

MIT

Last publish

Collaborators

  • khai96_