rc-editor-core
TypeScript icon, indicating that this package has built-in type declarations

0.8.10 • Public • Published

rc-editor-core


React EditorCore Component

NPM version build status Test coverage gemnasium deps node version npm download Sauce Test Status

Sauce Test Status

Browser Support

IE / Edge
IE / Edge
Firefox
Firefox
Chrome
Chrome
Safari
Safari
iOS Safari
iOS Safari
Chrome for Anroid
Chrome for Android
IE11, Edge [1, 2] last 2 versions last 2 versions last 2 versions not fully supported [3] not fully supported [3]

[1] May need a shim or a polyfill for some syntax used in Draft.js (docs).

[2] IME inputs have known issues in these browsers, especially Korean (docs).

[3] There are known issues with mobile browsers, especially on Android (docs).

Screenshots

Development

npm install
npm start

Example

http://localhost:8003/examples/

online example: http://react-component.github.io/editor-core/

Feature

  • support ie8,ie8+,chrome,firefox,safari

install

rc-editor-core

Usage

var EditorCore = require('rc-editor-core');
var React = require('react');
React.render(<EditorCore />, container);

API

props

name type default description
className String additional css class of root dom node

Test Case

npm test
npm run chrome-test

Coverage

npm run coverage

open coverage/ dir

License

rc-editor-core is released under the MIT license.

Package Sidebar

Install

npm i rc-editor-core

Weekly Downloads

91,662

Version

0.8.10

License

none

Unpacked Size

116 kB

Total Files

58

Last publish

Collaborators

  • afc163
  • raohai
  • yesmeck