Nucleus Powered Mitochondria
    Have ideas to improve npm?Join in the discussion! »

    protractor-dart

    0.0.5 • Public • Published

    Protractor for AngularDart

    Write Protractor end-to-end tests against your AngularDart applications using the Jasmine syntax.

    Your Dart could would depend on the protractor pub package.  For the runner, you would depend on the protractor-dart npm package.  You should depend on the same version number of both packages to keep the Dart and the JS code in sync.  (FYI, protractor-dart internally depends on a depends a fork of Protractor, protractor-dart)

    Running the demo

    • npm install
    • pub install (Do not forget this.)
    • Start a selenium server at localhost:4444. Refer the Protractor docs for help.
    • Start the test application server with node app/expressserver.js
    • Run the tests ./bin/protractor_dart test/conf.js

    Keywords

    none

    Install

    npm i protractor-dart

    DownloadsWeekly Downloads

    1

    Version

    0.0.5

    License

    MIT

    Last publish

    Collaborators

    • avatar