Noah's Pairwise Manifest

    pouchdb-browser-mc

    6.1.0 • Public • Published

    pouchdb-browser

    PouchDB, the browser-only edition. A preset representing the PouchDB code that runs in the browser, without any of the code required to run it in Node.js.

    The pouchdb-browser preset contains the version of PouchDB that is designed for the browser. In particular, it ships with the IndexedDB and WebSQL adapters as its default adapters. It also contains the replication, HTTP, and map/reduce plugins.

    Use this preset if you only want to use PouchDB in the browser, and don't want to use it in Node.js. (E.g. to avoid installing LevelDB.)

    Usage

    npm install pouchdb-browser
    var PouchDB = require('pouchdb-browser');
    var db = new PouchDB('mydb');

    For full API documentation and guides on PouchDB, see PouchDB.com. For details on PouchDB sub-packages, see the Custom Builds documentation.

    Source

    PouchDB and its sub-packages are distributed as a monorepo.

    For a full list of packages, see the GitHub source.

    Keywords

    none

    Install

    npm i pouchdb-browser-mc

    DownloadsWeekly Downloads

    6

    Version

    6.1.0

    License

    Apache-2.0

    Last publish

    Collaborators

    • sitapati