‚̧npm: possibly marvellous
    Have ideas to improve npm?Join in the discussion! ¬Ľ

    postcss-overflow-shorthand

    2.0.0¬†‚Äʬ†Public¬†‚Äʬ†Published

    PostCSS Overflow Shorthand PostCSS Logo

    NPM Version CSS Standard Status Build Status Support Chat

    PostCSS Overflow Shorthand lets you use the overflow shorthand in CSS, following the CSS Overflow specification.

    html {
      overflow: hidden auto;
    }
     
    /* becomes */
     
    html {
      overflow-x: hidden;
      overflow-y: auto;
      overflow: hidden auto;
    }

    Usage

    Add PostCSS Overflow Shorthand to your project:

    npm install postcss-overflow-shorthand --save-dev

    Use PostCSS Overflow Shorthand to process your CSS:

    const postcssOverflowShorthand = require('postcss-overflow-shorthand');
     
    postcssOverflowShorthand.process(YOUR_CSS /*, processOptions, pluginOptions */);

    Or use it as a PostCSS plugin:

    const postcss = require('postcss');
    const postcssOverflowShorthand = require('postcss-overflow-shorthand');
     
    postcss([
      postcssOverflowShorthand(/* pluginOptions */)
    ]).process(YOUR_CSS /*, processOptions */);

    PostCSS Overflow Shorthand runs in all Node environments, with special instructions for:

    Node PostCSS CLI Webpack Create React App Gulp Grunt

    Options

    preserve

    The preserve option determines whether the original overflow declaration is preserved. By default, it is preserved.

    postcssOverflowShorthand({ preserve: false })
    html {
      overflow: hidden auto;
    }
     
    /* becomes */
     
    html {
      overflow-x: hidden;
      overflow-y: auto;
    }

    Install

    npm i postcss-overflow-shorthand

    DownloadsWeekly Downloads

    3,556,769

    Version

    2.0.0

    License

    CC0-1.0

    Unpacked Size

    19 kB

    Total Files

    8

    Last publish

    Collaborators

    • avatar