Join us to discuss the challenges, solutions and best practices for in-house JavaScript code sharing. Tuesday, 12/17 at 10am PT/1pm ET.Sign up here »

postcss-fallback-cursors

0.1.0 • Public • Published

Fallback cursors plugin that plays nicely with Webpack LESS-loader and Autoprefixer.

Usage

const FallbackCursors = require('postcss-fallback-cursors');
FallbackCursors({
    'grabbing': 'url("path/to/grabbing.cur"), move'
});
 
/* add to PostCSS plugins */

so

.grabbing {
    cursor: grabbing;
}

becomes:

.grabbing {
    cursor: url("path/to/grabbing.cur")move;
    cursor: grabbing;
}

or maybe if you're using Autoprefixer:

.grabbing {
    cursor: url("path/to/grabbing.cur")move;
    cursor: -webkit-grabbing;
    cursor: grabbing;
}

API status

This module was created for the needs I have at the moment, and it doesn't account for edge cases.

So, this module API is not stable. It will wery likely be changed in the future.

I'm open for the suggestions and PRs even if those changes are breaking as hell.

Install

npm i postcss-fallback-cursors

DownloadsWeekly Downloads

57

Version

0.1.0

License

WTFPL

Last publish

Collaborators

  • avatar
  • avatar
  • avatar
  • avatar