postcss-downgrade-variables

    0.0.5-alpha.1 • Public • Published

    PostCSS Downgrade Variables Build Status

    PostCSS plugin for downgrade css variables.

    :root {
      --primary-background: #fff;
      --green-color: #0f0;
    }
    .class {
      background: var(--primary-background);
      background-image: linear-gradient(to topvar(--green-color)var(--primary-background));
    }
    :root {
      --primary-background: #fff;
      --green-color: #0f0;
    }
    .class {
      background: #fff;
      background: var(--primary-background);
      background-image: linear-gradient(to top#0f0#fff);
      background-image: linear-gradient(to topvar(--green-color)var(--primary-background));
    }

    Usage

    postcss([ require('postcss-downgrade-variables') ])

    See PostCSS docs for examples for your environment.

    Install

    npm i postcss-downgrade-variables

    DownloadsWeekly Downloads

    2

    Version

    0.0.5-alpha.1

    License

    MIT

    Last publish

    Collaborators

    • winte256