Nonconformist Propaganda Machine

    postcss-border-radius

    1.0.0 • Public • Published

    PostCSS Border Radius Build Status

    PostCSS plugin for border-radius shorthand.

    Usage

    postcss([ require('postcss-border-radius') ])

    Input:

    .top {
        border-top-radius: 5px;
    }
     
    .right {
        border-right-radius: 5px;
    }
     
    .bottom {
        border-bottom-radius: 5px;
    }
     
    .left {
        border-left-radius: 5px;
    }

    Output:

    .top {
        border-top-right-radius: 5px;
        border-top-left-radius: 5px;
    }
     
    .right {
        border-top-right-radius: 5px;
        border-bottom-right-radius: 5px;
    }
     
    .bottom {
        border-bottom-right-radius: 5px;
        border-bottom-left-radius: 5px;
    }
     
    .left {
        border-top-left-radius: 5px;
        border-bottom-left-radius: 5px;
    }

    See PostCSS docs for examples for your environment.

    Install

    npm i postcss-border-radius

    DownloadsWeekly Downloads

    8

    Version

    1.0.0

    License

    MIT

    Last publish

    Collaborators

    • jakelazaroff