polaris-spacing

1.2.3 • Public • Published

Polaris Spacing Plugin (v1.2.3)

In addition to the built-in features and components comes with Polaris framework, you can also use a set of useful plugins.

Polaris Spacing Plugin contains a set of responsive classes for controlling padding, and margin of HTML elements.

Documentation

Coming soon...

Dependencies

In general for production, Polaris Plugins depend on Polaris Framework Core CSS and/or JS libraries.

However, this specific plugin can be used stand alone. But, for development, it depends on:

Get Started

Install via npm

npm install polaris-spacing

Use Polaris CDN

Coming soon...

Download Polaris Spacing

Download Polaris Spacing

Clone Polaris

You can also clone Polaris Spacing using git:

git clone https://github.com/heminsatya/polaris-spacing.git

Customize Polaris Spacing

First, you need to download or clone it, then you need to follow a few easy steps:

  • Open up your favourite CLI program.
  • Change directory to the path where Polaris Spacing extracted:
cd path-to/polaris-spacing/
  • Install packages by:
npm install

Now, you have everything set-up. You can customize it however you want.

Next step after customization is to rebuild the CSS libraries.

  • To rebuild the CSS libraries run:
npm run css
npm run css-dev

Package Sidebar

Install

npm i polaris-spacing

Weekly Downloads

0

Version

1.2.3

License

MIT

Unpacked Size

530 kB

Total Files

15

Last publish

Collaborators

  • heminsatya