notebook

1.0.1 • Public • Published

Tonic Notebooks

Any notebook in Tonic can also be a node module, and can be required by any other notebook in Tonic like this:

require("notebook")("tonic/package-server/1.0.0")

Here, package-server is the name of the notebook, and 1.0.0 is the specific version we're requiring (using semver, of course).

Within Tonic this just works. Outside of Tonic, you can npm install this package to make these requires work.

Note: this package currently makes blocking calls, so you probably don't want to use it in performance sensitive places.

Readme

Keywords

none

Package Sidebar

Install

npm i notebook

Weekly Downloads

9

Version

1.0.1

License

MIT

Last publish

Collaborators

  • boucher