node-red-contrib-can

    1.1.2 • Public • Published

    node-red-contrib-can

    Node-RED node based on socketcan for reading a KCD file and handeling CAN-messages sent and received for this.

    Install

    Run the following command in your Node-RED user directory - typically ~/.node-red

        npm install node-red-contrib-can
    

    Usage

    You will need to have can-utils installed on your machine. Since this package is only available for unix systems you will need a unix machine to run this. sudo apt-get install can-utils should work in ubuntu.

    The node can be 'enabled' or 'disabled' by sending a 'msg.can' message of 'enable' or 'disable'. This makes it easy to to halt or start can messages while the flow is running or based of external logic.

    The node can also be configured to send a CAN message any time there is an update to the node, or only on change.

    Tips

    Since this only works with kayak (kcd) files I would recommend having a look at canmatrix which is a python tool to convert between different standards.

    Acknowledgements

    Thanks to sebi2k1 for his excellent NodeJs wrapper around socketcan. ebroecker for his canmatrix convertion tool.

    Install

    npm i node-red-contrib-can

    DownloadsWeekly Downloads

    1

    Version

    1.1.2

    License

    MIT

    Unpacked Size

    45.4 kB

    Total Files

    14

    Last publish

    Collaborators

    • bbqsrc
    • tc-admin
    • oskarhagberg
    • zbrox
    • rawa90
    • spanken