Nimoy Prospers Mystically
Have opinions about JavaScript? We want to hear them. Take the 2018 JavaScript Ecosystem Survey »

This package has been deprecated

Author message:

This package is deprecated - please use the cricapi package instead

node-cricapi

1.2.6 • Public • Published

The Cric API are a set of free high-bandwidth, high-performance API designed for public use.

You can call the following functions within this module:

var cricapi = require("node-cricapi");

cricapi.cricketMatches(function(databundle){ // Variable "databundle" now contains JSON data in the below form });

// format of databundle { "cache": true, "data": [ { "unique_id": "918033", "description": "India A 161/1 * v Bangladesh A 228/10 ", "title": "India A 161/1 * v Bangladesh A 228/10 " }, { "unique_id": "903767", "description": "Kenya 119/10 v South Western Districts 118/5 *", "title": "Kenya 119/10 v South Western Districts 118/5 *" }, { "unique_id": "919603", "description": "Zimbabwe 123/9 * v Pakistan 136/8 ", "title": "Zimbabwe 123/9 * v Pakistan 136/8 " }, { "unique_id": "903769", "description": "Free State 110/7 v Gauteng 102/8 *", "title": "Free State 110/7 v Gauteng 102/8 *" }, { "unique_id": "918665", "description": "Pakistan Association of Hong Kong v Hong Kong Cricket Association Under-19s", "title": "Pakistan Association of Hong Kong v Hong Kong Cricket Association Under-19s" } ], "provider": { "pubDate": "2015-09-27T16:20:02.757Z", "source": "", "url": "http://crm.wherrelz.com/" } }

API Usage documentation may be found at http://www.cricapi.com/how-to-use.aspx

install

npm i node-cricapi

Downloadsweekly downloads

19

version

1.2.6

license

ISC

last publish

collaborators

  • avatar
Report a vulnerability