node-api-version
    TypeScript icon, indicating that this package has built-in type declarations

    0.1.4 • Public • Published

    node-api-version

    Get the maximum Node-API version supported for a specific version of node or Electron.

    const { fromNodeVersion, fromElectronVersion } = require("node-api-version");
    
    fromNodeVersion("9.0.0"); // undefined
    fromNodeVersion("12.13.0"); // 5
    
    fromElectronVersion("2.0.0"); // undefined
    fromElectronVersion("13.0.0"); // 7
    fromElectronVersion("15.0.0-nightly.20210629"); // 8

    Keywords

    none

    Install

    npm i node-api-version

    DownloadsWeekly Downloads

    89,589

    Version

    0.1.4

    License

    MIT

    Unpacked Size

    5.61 kB

    Total Files

    6

    Last publish

    Collaborators

    • timfish