ngfds
TypeScript icon, indicating that this package has built-in type declarations

10.0.1 • Public • Published

ngfds

An Angular Component Library implemeting DKFDS - Fælles Design System

Builds

Angular version Compatible versions Recommended install command Supported untill Status
15.0.0 - <16.0.0 15.X.X.X Unknown Supported
14.0.0 - <15.0.0 14.X.X.X npm install ngfds@14 Dec 2025 Supported
13.0.0 - <14.0.0 13.X.X.X npm install ngfds@13 May 2025 Supported
12.0.0 - <13.0.0 12.X.X.X npm install ngfds@12 Nov 2024 Supported
11.0.0 - <12.0.0 11.X.X.X npm install ngfds@11 May 2024 Supported
10.1.0 - <11.0.0 10.X.X.X npm install ngfds@10 Dec 2023 Supported
9.1.0 - <10.0.0 9.X.X.X npm install ngfds@9 May 2023 Supported

Github

GitHub issue custom search in repo GitHub commit activity GitHub repo size

Codeclimate

Code Climate maintainability Code Climate issues Code Climate technical debt

https://codeclimate.com/github/Flaeng/ngfds

Codefactor

CodeFactor Grade

https://www.codefactor.io/repository/github/flaeng/ngfds

Version schema

Major version is always the Angular version that the package is compatible with Minor is the version of FDS that it is using Patch & Build are ngfds versions

What does that mean?

It means if you're running a Angular 13 project you have to install a package with the major version 13 untill you upgrade your @angular/core package.

If you have other dependencies using FDS you can use the install command npm install ngfds~X.Y where X is your Angular version and the major version of FDS that you want to stay within. This way when both ngfds and your other dependencies that depends on FDS both support i.e. version 9 of FDS you can upgrade ngfds to version ngfds~X.Z where Z is the new version of FDS that you want to install.

Package Sidebar

Install

npm i ngfds

Weekly Downloads

3

Version

10.0.1

License

MIT

Unpacked Size

2.63 MB

Total Files

353

Last publish

Collaborators

  • flaeng