Have ideas to improve npm?Join in the discussion! »

    mamba

    0.0.2 • Public • Published

    node-mamba

    Mamba.ru API wrapper for node.js. It cares single dependency (md5).

    Installation

    npm i --save mamba

    Usage

    Initialize.

    var MambaApi = require("mamba");
    var mamba = new MambaApi(appId, appSecret[, appPrivate]);
    

    Then use it like this:

    mamba.request("achievement.set", {
        sid: sid,
        text: text,
        extra_params: extra_params
    }, callback);
    ...
    

    Or use helper methods:

    mamba.achievementSet(sid, text, extra_params, cb);
    mamba.anketaGetFlags(oids, cb);
    mamba.anketaGetHitlist(sid, period, limit, offset, blocks, ids_only, cb);
    mamba.achievementSet({
        sid: sid,
        text: text,
        extra_params: extra_params
    }, cb);
    ...
    

    License

    MIT

    Install

    npm i mamba

    DownloadsWeekly Downloads

    1

    Version

    0.0.2

    License

    MIT

    Last publish

    Collaborators

    • avatar