magick-loader

    1.0.0 • Public • Published

    magick-loader

    A webpack loader for processing images with GraphicsMagick.

    Installation

    1. Install GraphicsMagick
    2. npm install --save-dev magick-loader
    3. If the loader doesn't work, try installing ImageMagick

    Usage

    require('file!img!magick?-resize 1920x1080!./image.jpg');

    The query string (-resize 1920x1080 in the example) will be passed to GraphicsMagick as command line parameters (gm's .out() method is used for this).

    Install

    npm i magick-loader

    DownloadsWeekly Downloads

    1

    Version

    1.0.0

    License

    MIT

    Last publish

    Collaborators

    • axtgr