Wondering what’s next for npm?Check out our public roadmap! »

    listr-verbose-renderer

    0.6.0 • Public • Published

    listr-verbose-renderer Build Status

    Listr verbose renderer

    Install

    $ npm install --save listr-verbose-renderer
    

    Usage

    const VerboseRenderer = require('listr-verbose-renderer');
    const Listr = require('listr');
     
    const list = new Listr([
        {
            title: 'foo',
            task: () => Promise.resolve('bar')
        }
    ], {
        renderer: VerboseRenderer
    });
     
    list.run();

    Note: This renderer supports non-TTY environments.

    Options

    These options should be provided in the Listr options object.

    dateFormat

    Type: string false
    Default: HH:mm:ss

    Format of the rendered timestamp. Use the date-fns string format. If false is passed in, the timestamp will be hidden.

    Related

    License

    MIT © Sam Verschueren

    Install

    npm i listr-verbose-renderer

    DownloadsWeekly Downloads

    3,923,589

    Version

    0.6.0

    License

    MIT

    Unpacked Size

    4.83 kB

    Total Files

    5

    Last publish

    Collaborators

    • avatar