less-plugin-csscomb

    0.0.2 • Public • Published

    less-plugin-csscomb

    CSScomb helps you sort and categorize CSS properties in your code to improve maintenance of your stylesheets.

    lessc usage

    Install..

    npm install -g less-plugin-csscomb
    

    and then on the command line,

    lessc file.less --csscomb
    

    You can chose between the following configuration: csscomb (default), zen or yandex. The preceding configuration can be passed as an argument to the plugin:

    lessc file.less --csscomb="yandex"
    

    Alternatively use your own custom configuration by providing the path as an argument to the plugin:

    lessc file.less --csscomb="test.js"
    

    Programmatic usage

    var LessPluginCSScomb = require('less-plugin-csscomb'),
        csscombPlugin = new LessPluginCSScomb("zen");
    less.render(lessString, { plugins: [csscombPlugin] })
      .then(
    

    Browser usage

    Browser usage is not supported at this time.

    Install

    npm i less-plugin-csscomb

    DownloadsWeekly Downloads

    43

    Version

    0.0.2

    License

    none

    Last publish

    Collaborators

    • bassjobsen