The name "dispatcher" is actually misleading. It could be better
named "koa-composer", as it composes multiple handlers into one,
using flexible rules to decide the handler(s) to execute; but I
named it "dispatcher", to avoid unnecessary confusions with the
existing (and used in koa core)
Documentation is to be updated to reflect the recent major refactor.