Nihilist Pocket Monsters

npm

Need private packages and team management tools?Check out npm Orgs. »

katt-util

0.1.3 • Public • Published

KATT util Build Status

KATT utilities for KATT blueprints.

Install

# NPM distribution 
npm install katt-util
 
# GIT source 
git clone --recurse-submodules https://github.com/klarna/katt-util.git
npm install

Usage

Linter

katt-lint FOLDER/FILE ...
# katt-lint -h for options 
kattUtil = require 'katt-util'
kattBlueprint = '...'
 
errors = kattUtil.lint kattBlueprint
 
if errors.length # if there are errors 
  console.log errors.length[0# {type, native, details} 

Formatter

katt-format FOLDER/FILE ...
# katt-format -h for options 
kattUtil = require 'katt-util'
kattBlueprint = '...'
 
beautifulKattBlueprint = kattUtil.format kattBlueprint

HAR-to-KATT converter

har2katt FILE ...
kattUtil = require 'katt-util'
har = '...'
 
kattBlueprint = kattUtil.har2katt harr

License

Apache 2.0

Keywords

none

install

npm i katt-util

Downloadsweekly downloads

1

version

0.1.3

license

none

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
  • avatar
  • avatar
Report a vulnerability