Necessarily Precedes Mischief

    jmessage-phonegap-plugin

    4.1.4 • Public • Published

    JMessage PhoneGap / Cordova Plugin

    release platforms Code Triagers Badge weibo

    极光官方开发的极光 IM cordova 插件,目前支持 iOS 和 Android 平台。

    若只需要简单的聊天功能,可优先考虑使用 JMessage Web SDK

    注意:从 v3.4.0 开始支持 cordova-android 7.0.0,因 cordova-android 7.0.0 修改了 Android 项目结构,因此不兼容之前的版本,升级前请务必注意。

    如果需要在cordova-android 7.0.0之前版本集成最新插件,参照这篇文章

    如果需要安装之前版本的插件,请先安装 v1.2.0 以下版本(建议安装 v1.1.12)的 cordova-plugin-jcore,再安装旧版插件(建议v3.2.0),否则运行会报错。

    Cordova Android版本与原生版本对应表

    Full Documentation

    完整文档请查阅 wiki,包括安装指南API 说明等。

    Contribute

    Please contribute! Look at the issues.

    Support

    Install

    npm i jmessage-phonegap-plugin

    DownloadsWeekly Downloads

    299

    Version

    4.1.4

    License

    MIT

    Unpacked Size

    79.6 MB

    Total Files

    58

    Last publish

    Collaborators

    • hev1n
    • huminios
    • josh_lipan
    • jpush
    • wicked-tc130