npm

Ready to take your JavaScript development to the next level? Meet npm Enterprise - the ultimate in enterprise JavaScript. Learn more »

jhipster-vuejs

0.0.0 • Public • Published

JHipster-vuejs [WIP]

NPM version Build Status Dependency Status

⚠️ Status: in development

JHipster-vuejs, a Vue.js blueprint for JHipster. It will use Vue.js as the frontend library

Introduction

This is a JHipster blueprint.

Prerequisites

As this is a JHipster blueprint, we expect you have JHipster and its related tools already installed:

Installation (Only after stable release, for now use the development flow)

With NPM

To install this blueprint:

npm install -g jhipster-vuejs

To update this blueprint:

npm update -g jhipster-vuejs

With Yarn

To install this blueprint:

yarn global add jhipster-vuejs

To update this blueprint:

yarn global upgrade jhipster-vuejs

Usage

To use this blueprint, run

jhipster --blueprint vuejs

Running local Blueprint version for development

During development of blueprint, please note the below steps. They are very important.

  1. Clone this repo locally and cd into it, then link your blueprint globally
git clone https://github.com/jhipster/jhipster-vuejs.git
cd jhipster-vuejs
npm link
  1. Optional: Link a development version of JHipster to your blueprint (optional: required only if you want to use a non-released JHipster version, like the master branch or your own custom fork)
cd generator-jhipster
npm link
 
cd jhipster-vuejs
npm link generator-jhipster
  1. Create a new folder for the app to be generated and link JHipster and your blueprint there
mkdir my-app && cd my-app
 
npm link jhipster-vuejs
npm link generator-jhipster (Optional: Needed only if you are using a non-released JHipster version)
 
jhipster -d --blueprint vuejs
 

License

Apache-2.0 © Deepu K Sasidharan

install

npm i jhipster-vuejs

Downloadsweekly downloads

2

version

0.0.0

license

Apache-2.0

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
  • avatar
  • avatar
  • avatar
Report a vulnerability