hyper-lrlld-statusline

1.9.0 • Public • Published

hyper-statusline hyper npm npm

Status Line Plugin for Hyper. Shows clickable & useful information. Matches any theme.

hyper-statusline

Install

Add following to your ~/.hyper.js config.

module.exports = {
  ...
  plugins: ['hyper-statusline']
  ...
}

Config

Add following to ~/.hyper.js

Change Git Dirty Color

Expected value is CSS color

module.exports = {
  config: {
    ...
      hyperStatusLine: {
        dirtyColor: 'salmon',
      }
    ...
  }
}

Change Git Ahead Color

Expected value is CSS color

module.exports = {
  config: {
    ...
      hyperStatusLine: {
        aheadColor: 'ivory',
      }
    ...
  }
}

Default value is set to true

module.exports = {
  config: {
    ...
      hyperStatusLine: {
        footerTransparent: false,
      }
    ...
  }
}

Theme

License

MIT © Henrik

Package Sidebar

Install

npm i hyper-lrlld-statusline

Weekly Downloads

7

Version

1.9.0

License

MIT

Unpacked Size

20 kB

Total Files

4

Last publish

Collaborators

  • lyrillind