node package manager

hapi-heartbeat

Hapi hearbeat

Build Status NPM version Dependencies

Shared code for the heartbeat endpoint.

Installation:

npm install hapi-heartbeat

Usage:

var server = hapi.createServer();
 
server.pack.require("hapi-heartbeat",
  {
    liveness: '/my/api/123',
    route: '/heartbeat' (optional: default to /heartbeat)
    headers: {
    // optional headers to apply when making the liveness check
      'accept-language': 'en-US'
    },
  },
  function (err){
    if(err){
      throw err;
    }
  }
);

Response Codes:

  • 200
  • 503

Notes:

  • Supports pack servers as well as single instances
  • Supports hapi v5+