This package has been deprecated

    Author message:

    This version contains severe security issues and defects and should not be used! Please upgrade to the latest version of @hapi/hapi or consider a commercial license (https://github.com/hapijs/hapi/issues/4114)

    hapi
    DefinitelyTyped icon, indicating that this package has TypeScript declarations provided by the separate @types/hapi package

    18.1.0 • Public • Published

    Web and services application framework

    Lead Maintainer: Eran Hammer

    hapi is a simple to use configuration-centric framework with built-in support for input validation, caching, authentication, and other essential facilities for building web and services applications. hapi enables developers to focus on writing reusable application logic in a highly modular and prescriptive approach.

    Version 18.x only supports node v8.12.0 and over. For older version of node please use hapi version 16.x.

    Development version: 18.1.x (release notes) Linux Build Status Windows Build Status

    For the latest updates, change log, and release information visit hapijs.com and follow @hapijs on twitter. If you have questions, please open an issue in the discussion forum.

    Sponsorship

    Development of the hapi core module generously supported by contributions from individuals and corporations. If you are benefiting from hapi and would like to help keep the project financially sustainable, please visit Eran Hammer's Patreon page or contact him via email.

    Featured Sponsors

    Auth0

    Active Supporters

    Legacy Supporters

    Past major financial support for the project was provided by:

    Install

    npm i hapi

    Homepage

    hapijs.com

    DownloadsWeekly Downloads

    104,703

    Version

    18.1.0

    License

    BSD-3-Clause

    Unpacked Size

    180 kB

    Total Files

    25

    Last publish

    Collaborators

    • hueniverse