Ninjas Practicing Multidimensionality
Have opinions about JavaScript? We want to hear them. Take the 2018 JavaScript Ecosystem Survey »

gulp-uglifyes

0.2.1 • Public • Published

gulp-uglifyes

Please use terser / gulp-terser instead of uglify-es / gulp-uglifyes.

Gulp plugin, compressed es6+ code.

Install

$ npm install gulp-uglifyes --save-dev

or

$ yarn add gulp-uglifyes --dev

How to use

const gulp = require('gulp');
const uglify = require('gulp-uglifyes');
 
function es(){
  return gulp.src('./src/index.js')
    .pipe(uglify())
    .pipe(gulp.dest('./build'));
}
 
gulp.task('default', es);

Options

Uglify-es configuration can be viewed https://github.com/mishoo/UglifyJS2/tree/harmony#minify-options.

const gulp = require('gulp');
const uglify = require('gulp-uglifyes');
 
function es(){
  return gulp.src('./src/index.js')
    .pipe(uglify())
    .pipe(gulp.dest('./build'));
}
 
gulp.task('default', es);

install

npm i gulp-uglifyes

Downloadsweekly downloads

970

version

0.2.1

license

MIT

last publish

collaborators

  • avatar
Report a vulnerability