Wondering what’s next for npm?Check out our public roadmap! »

gulp-ccaas

0.0.1 • Public • Published

gulp-ccaas

Compiles JavaScript with the Google Closure Compiler Service API, run and hosted by Google. Similar to gulp-closure-compiler, but does not require Java or the compiler code directly.

Install

npm install --save-dev gulp-ccaas

Example

While there are many options for the raw HTTP API, this plugin just compiles ES6 to ES5.

It takes two options- strict (default true) and advanced (default false). For more information on the advanced mode, see Advanced Compliation and Externs.

var gulp = require('gulp');
var closure = require('gulp-ccaas');
 
gulp.task('default', function() {
  return gulp.src('your-src.js')
      .pipe(closure({
        advanced: true,
        strict: false
      }))
      .pipe(gulp.dest('out'));
});

Install

npm i gulp-ccaas

DownloadsWeekly Downloads

1

Version

0.0.1

License

Apache-2.0

Last publish

Collaborators

  • avatar