grunt-tsd

Grunt plugin to run TSD

grunt-tsd

Grunt plugin to automate tsd and TypeScript definition related tasks

This plugin requires Grunt ~0.4.1

If you haven't used Grunt before, be sure to check out the Getting Started guide, as it explains how to create a Gruntfile as well as install and use Grunt plugins. Once you're familiar with that process, you may install this plugin with this command:

$ npm install grunt-tsd --save-dev

Once the plugin has been installed, it may be enabled inside your Gruntfile with this line of JavaScript:

grunt.loadNpmTasks('grunt-tsd');
grunt.initConfig({
    tsd: {
        refresh: {
            options: {
                // execute a command 
                command: 'reinstall',
 
                //optional: always get from HEAD 
                latest: true,
 
                // optional: specify config file 
                config: '../conf/tsd.json',
 
                // experimental: options to pass to tsd.API 
                opts: {
                    // props from tsd.Options 
                }
            }
        }
    }
})
  • 0.1.0 - reinstall always resolves dependencies, saves to config/bundle and overwrites
  • 0.0.2 ... 0.0.4 - Updating TSD version to 0.5.6
  • 0.0.1 - First release for TSD 0.5.2

Contributions are very welcome, please create an Issue before doing something major.

In lieu of a formal styleguide, take care to maintain the existing coding style. Add unit tests for any new or changed functionality. Lint and test your code using Grunt.