global-scope

Require global variables